XT power supply problems

More
10 months 1 week ago #1 by efexor
Hi,

I have a XT and somebody used a wrong power supply.
There are 2 resistors burned.(check pic)

Anyone who knows the values please?

Thanks,
Attachments:

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #2 by Qwave
Replied by Qwave on topic XT power supply problems
I can't see the colors of the resistors in the picture (most likely not yours, as your resistors are now burned) good enough to be sure about them. And guessing the colours is not helpful. Sorry. And Waldorf never released their schematics to the public.
But you might ask the Waldorf support. They should no this for sure.

And check the black ESD Suppressors / TVS Diodes 400W 15V Bidirect that is mounted between the marked resistors as well.

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #3 by efexor
Replied by efexor on topic XT power supply problems
Thanks for the answer.

I had a message from a Waldorf employee who is helping me out.

Cheers,

Please Log in or Create an account to join the conversation.

More
10 months 1 week ago #4 by Qwave
Replied by Qwave on topic XT power supply problems
Please post the values for these two resistors, so others can find a solution when it happens to them.

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #5 by efexor
Replied by efexor on topic XT power supply problems
So tech support from Waldorf send me a kit to replace the most important parts in the powerline.
And guess what: it's working again!!!

Big thumbs up to Karsten from Waldorf for helping me out.

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #6 by Qwave
Replied by Qwave on topic XT power supply problems
Please share which parts you got and where to place them. This will help others.

Please Log in or Create an account to join the conversation.